mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik EA204 im SPI Mode (KS0073, LCD)


Autor: Wolfgang (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wieder mal LCD :-(

Also: Ich versuche ein EA204 (blau weiss) mit KS0073 per SPI ans Laufen 
zu bringen. VCC=3V3.
Prozessor ist ein Atmega AVR. Den Jumper auf dem Display habe ich 
umgelötet. Ich sehe meine Zugriffe auf dem CS, SPI_CLK kommen 8 Takte im 
passenden Tempo (0.8us, müßte der KS0073 lt. Dabla können). Meine Daten 
kommen auch auf MOSI, leider aber keine Antwort auf MISO.

Rausschreiben tue ich die im Datenblatt angegebene Sequenz zum Init; 
wobei ich diese auch am Scope sehen kann. Die Suche hat mir noch nicht 
entscheidend weiter geholfen.

Frage: Schiebt der Kontroller die Daten von MOSI nicht auf MISO durch? 
Ansonsten bin ich für Bemerkungen und Tipps dankbar.

Gruß Wolfgang

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.