mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP-Selberbau: Kurzer?


Autor: shoXy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Wollte erstmal sagen, dass ich die Seite hier super finde!

Hab mir nun soweit das meiste durchgelesen und bin gerade dabei die
Programmiereinheit zu bauen. Dazu muss ich sagen, dass ich in sachen
Microcontroller und IC´s der MEGA-NOOBIE bin. ;-) Allerdings bin ich
aber auch nicht gerade ungeschickt. Ich möchte deswegen schon begreifen
wie das alles funktioniert und es auch später nutzen.

Mein Problem:

Ich habe jetzt die ISP Schaltung auf einem Breadboard aufgebaut. Aber
sobald ich VCC und GND mit den zugehörigen Kontakten verbinde reagiert
mein Labornetzteil wie bei einem Kurzschluss(A lässt sich ohne Ende
steigern). Ich hab alles schon kontrolliert aber es ist alles
angeschlossen wie auf eurem Schaltplan.

VIELEN DANK JUNX!!!

mit besten Grüßen,
shoXy

Autor: Werner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du alle bauteile runternimmst, ist dann der Kurzschluss immer noch
da? Den Schaltplan haben schon ganz viele erfolgreich nachgebaut. Ich
würde also eher bei Dir suchen...

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe exakt das gleiche Problem!

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach welcher Schaltung habt ihr den ISP denn aufgebaut?
Ohne die könnte die Fehlersuche ein bischen schwierig werden.
Prinzipiell braucht man doch da auch nicht viele Bauteile, ein 74HC244
reicht eigentlich (je nach Programmer).
Also bitte mehr Infos.

Gruss Alex

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nach der Bauanleitung wie sie in der Tutorial
steht.(HCT+DIODE+C+Widerstand) Hmm kann man evtl den programmer einzeln
testen? ohne AvR? Die Schaltung ist korrekt aufgebaut? Kann ich
irgendwelche Sachen nachmessen?

Die Verschaltung der Schottky Diode kommt mir ein bisschen merkwürdig
vor. Und im Schaltplan ist die Verschaltung des PIN 20 gar nicht
angegeben, auf der Platine schon?!?!!
Danke

Autor: Alex (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, den habe ich nicht verwendet. Versuch doch einfach mal den im
Anhang dargestellten. Den hat ein Kumpel von mir gestern
zusammengelötet und er ging auf Anhieb.
Dort spart man sich auch die zusätzlichen Bauteile.
Diese Art von Programmer nennt sich dann STK200-kompatibel oder so ;-)

Gruss Alex

Autor: AbsoluteBeginner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: MasterD (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bin auch grad dabei mir den ISP Adapter von lancos zu bauen, und
habe eine Frage:
wie ist das mit dem Pin "LED" ?
Das man da eine LED anschliessen kann die den Brennvorgang Visualisiert
weiss ich. Aber wie muss man die anschliessen? Gegen plus oder gegen
minus? Ist der Pin also Low-Aktiv oder High-Aktiv? Und inwiefern ändert
die LED ihren Zustand? leushtet wenn fertig, oder während geschrieben
wird?

Vielen Dank für hilfreiche Antworten schonmal im Vorraus,
MasterD

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo habe entsprechend lancos umgelötet und siehe da: läuft ohne
probs!

Fettes Merci!
Ich gehe davon aus dass du die Diode auf der Anderen Seite auf Ground
schaltest..ich guck gleich mal

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also: Der Port ist im Ruhezustand auf High, das bedeutet du musst +5 an
der kathode und den anderen halt an dem port tun

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kleinen Vorwiderstand nicht vergessen..

Autor: MasterD (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnelle Antwort.
wenn der port im Ruhezustand auf 5V liegt leuchtet die Diode nicht.
Wann schaltet der Port dann auf Low? Während des Brennvorgangs oder
wenn er fertig ist? Währe nur Interresant, damit ich weiss, was ich
erwarten muss wenn alles keklappt hat.
Danke
MasterD

Autor: David (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Während  des Lese/Brennvorgans schaltet er auf low und die LED leuchtet
während dieser Zeit.

Ob man damit einen erfolgreichen upload sehen denke ich nicht.Da bin
ich allerdings überfragt...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.