mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega8 Uart ausgangspegel invertiert


Autor: Parabol (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo leute
wie kann das sein?
 Wenn ich meinen Mega8 direkt über UArt an den PC anschließe bekomm ich 
eine komunikation. wenn ich aber einen Max232 anschließe passiert nix 
mir ist aufgefallen das der TXD ausgang die ganzezeit auf high ist.. das 
doch falsch?

danke schon mal

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>mir ist aufgefallen das der TXD ausgang die ganzezeit auf high ist.. das
>doch falsch?

Nein. Siehe Datenblatt S.137. Der Max232 'invertiert'. Negative 
Spannung=H, positive Spannung=L.

MfG Spess

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.