mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LPC21xx und RFM12


Autor: MSVWORK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe folgendes Problem.
Nutze einen LPC2103 von Olimex zur Ansterung eines RFM12 Moduls.
Die Initialisierung des Moduls läuft problemlos, 10 MHz am CLK!
Allerdings ist es mir nicht möglich, bei Statusabfrage (0x0000) die über 
MISO übertragenden Daten vom Slave zum Master zu empfangen. Ich messe 
dabei mit einem Oszi den SDO - Pin, welcher allerings immer null ist.
Die Port - Pins für SPI (MISO, MOSI und SCK) sind im PINSEL0 Register 
konfiguriert.

Jetzt meine Frage warum ist die SDO - Leitung des RFM12 - Moduls ständig 
null? Oder muss ich irgendwie das SPI - Interface konfigurieren, damit 
der Datenempfang über MISO erfolgen kann.

Über Anregungen oder Hinweisen, woran es liegen könnte wäre ich sehr 
erfreut.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.