mikrocontroller.net

Forum: Compiler & IDEs msp mit I²C


Autor: KoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moinsen alle miteinander :)

ich bin mal wieder auf der suche nach einem tutorial in sachen msp430
(immernoch ein mspf149, mspgcc,...).
und zwar suche ich eins, in dem beschrieben wird, wie ich mit dem msp
I²C bauteile anspreche...

oder ein bis zwei beispiele würden mir schon helfen...
was und wie es funktioniert weiß ich ja schon (hab schon erfahrungen
mit dem I²C bus mit dem IOW40 von codemercs machen können).

ich hab hier auch das msp-praxis-buch rumliegen, aber da steht dazu
auch nicht wirklich viel drinne :(

mfg KoF

Autor: KoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat denn noch niemand mit dem i²c am msp gearbeitet???

ich habe hier noch 2 8ch 12 bitige adc`s (ads7828e) und wollte auch
weitere i²c komponente vebauen (wie i²c rams, expander,...), doch ich
finde nirgens eine initialisierung für i²c :( ich weiß, das ich lieber
einen 169 statt eines 149 verwenden sollte, doch habe ich ihn nicht :(

Autor: nobody0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der msp430-usergroup bei yahoo gibt's Code dazu.
Ich habe solchen Code von meinem Vorgänger übernommen und damit werden
hier Daten im EEPROM gespeichert.
Der 149 hat I2C nicht in Hardware; da muß man emulieren. Zumind. beim
EEPROM ist das aber leicht.

Autor: KoF (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hmm der sieht mir aber sofern ich mich nicht teusche sehr nach spi aus,
oder??

ich hänge den mal dran, vielleicht könnt ihr mir sagen, ob ich falsch
liege...

Autor: KoF (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ok ok... ich habe jetzt mal rumgedoktort... viel gelesen, probiert,...

jetzt seht doch mal den code an, ob der so funtioniert, wie er soll und
falls er fehler beinhaltet, sagt es mir bitte :)

mfg KoF
ps schönes wochenende

Autor: KoF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, erste fehler sind schon gefunden :(

1. ich habe einen der beiden pins vergessen zu initialisieren
(erschießt mich ruhig für diesen fehler)
2. ich habe die start flanke falsch gesetzt...
...

sucht bitte weiter

mfg KoF

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.