mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMEGA Inbetriebnahme


Autor: Oswald Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey zusammen,

hab meine neue Platine mit einem ATMEGA128L drauf gestern bekommen und
wollte ihn heute in Betrieb nehmen. Leider reagiert er auf gar nichts.
Habs mit dem AVR-JTAG und dem SPI probiert...nichts. Hab also ne zweite
Platine genommen und nur den MCU, Quarz und C's draufgepackt. Reagiert
rtozdem nicht, selbst nach dem tausch des ATMEGA's.
Spannung liegt an, aber an den Quarzleitungen kann ich auch nichts
messen.
Sehr eigenartig...
Muss der speziell initialisiert werden oder weiß jemand nen
Lösungsvorschlag?

Danke

Autor: mthomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan wuerde helfen. Resetleitung "hochgezogen"? Spannung stabil?
Programmer funktioniert ansonsten, also mit anderen Boards getestet? Ist
der Programmer auch mit Strom versorgt (extern oder vom Zielsystem)?

Autor: Jörg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Richtige Leitungen für ISP benutzt?  Beim ATmega128 sind das nicht
MISO/MOSI.

Autor: Oswald Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,

danke schonmal. Hab ein Problem bei der Spannungsversorgung entdeckt.

Mario

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lass am Anfang vielleicht auch mal den Quarz und die zwei Kondensatoren
weg. Im Auslieferungszustand des ATmega128 ist der interne
1MHz-Oszillator aktiviert und im Datenblatt steht irgendwo, daß XTAL1
und XTAL2 in diesem Fall unbeschaltet bleiben sollen.

Thorsten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.