mikrocontroller.net

Forum: PC Hard- und Software o2 Surfstick unter Ubuntu 9.04


Autor: Andre I. (dex) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich musste wegen einer falschen Packetquelle in de Repositorys und einem 
damit einhergehendem Totalabsturz nach dem Systemupdate Ubuntu neu 
installieren.

Heute habe ich dann meinen o2 Surfstick nutzen wollen, der bis zum Crash 
keinerlei Probleme machte und auch Out of the box von Ubuntu erkannt 
wurde. Jetzt verweigert er aber seinen Dienst. lsusb listet ihn zwar 
auf, aber der gnome netzwerkmanager erkennt den stick nicht.

Ebenfalls ist mir aufgefallen, das ich unter ifconfig keine ppp0 
Schnittstelle mehr angezeigt bekomme. Vor dem Crash lief der Stick aber 
über eben diese.

/var/log/syslog meldet beim einstecken des Sticks folgendes:

Sep 25 21:21:00 ubuntu kernel: [  287.715868] usb 2-4: new high speed 
USB device using ehci_hcd and address 5
Sep 25 21:21:00 ubuntu kernel: [  287.859852] usb 2-4: configuration #1 
chosen from 1 choice
Sep 25 21:21:00 ubuntu kernel: [  287.861179] usb-storage: probe of 
2-4:1.0 failed with error -5
Sep 25 21:21:00 ubuntu kernel: [  287.861211] option 2-4:1.0: GSM modem 
(1-port) converter detected
Sep 25 21:21:00 ubuntu kernel: [  287.861376] usb 2-4: GSM modem 
(1-port) converter now attached to ttyUSB0
Sep 25 21:21:00 ubuntu kernel: [  287.861681] usb-storage: probe of 
2-4:1.1 failed with error -5
Sep 25 21:21:00 ubuntu kernel: [  287.861706] option 2-4:1.1: GSM modem 
(1-port) converter detected
Sep 25 21:21:00 ubuntu kernel: [  287.861793] usb 2-4: GSM modem 
(1-port) converter now attached to ttyUSB1
Sep 25 21:21:00 ubuntu kernel: [  287.865658] usb-storage: probe of 
2-4:1.2 failed with error -1
Sep 25 21:21:00 ubuntu kernel: [  287.866275] usb-storage: probe of 
2-4:1.3 failed with error -1
Sep 25 21:21:00 ubuntu NetworkManager: <info>  (ttyUSB1): ignoring due 
to lack of mobile broadband capabilties
Sep 25 21:21:00 ubuntu NetworkManager: <info>  (ttyUSB0): ignoring due 
to lack of mobile broadband capabilties

jemand eine Idee was ich noch versuchen könnte damit der Stick wieder 
rennt?

Autor: Ronny Minow (hobby-coder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls Du den O2 Surfstick "ICon 210" von Qualcom (aus dem O2 Look 
Surftsick 2 Paket) verwendest, sollte dies helfen: 
http://wiki.ubuntuusers.de/Icon_210

* Du brauchst "USB ModeSwitch", die Device und Vendor ID und ein wenig 
Zeit und gedult...

* Schalte die Pin Abfrage aus, sofern noch nicht getan. Es klappt auch 
mit Pin Abfrage, dann aber brauchst Du das Programm "comgt".

* Du brauchst ggf. noch ein paar Scripte, sofern Du nicht alles über den 
Network Manager machen willst.

Was zu tun ist, kannst Du auf oben genannten Wiki Eintrag lesen. Ach ja, 
im Ubuntu Forum wird das Thema bereits ausreichend besprochen...

Autor: Andre I. (dex) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich benutzte einen stick von huawei
██ 10:24:01 $ lsusb
Bus 002 Device 003: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 
HSDPA Modem / E270 HSDPA/HSUPA Modem

der gelinkte artikel dürfte also nicht das problem sein. es ging ja auch 
bis zum reinstall ohne weiteres

Autor: Ronny Minow (hobby-coder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du, oder ein Bekannter, ein PC mit Windows (XP) ? Wenn ja, versuche 
mal den Stick da zum mitspielen zu überreden. Falls er da nicht 
mitspielt, könnte er evtl. defekt sein...

Autor: Andre I. (dex) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf meinem Desktop Rechner läuft der Stick

Autor: Ronny Minow (hobby-coder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andre I. schrieb:
> Auf meinem Desktop Rechner läuft der Stick

Unter welchem OS...?

Autor: Andre I. (dex) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Windows 7. Ich denke du wolltest wissen ob der Stick überhaupt 
funktioniert

Autor: Ronny Minow (hobby-coder)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andre I. schrieb:
> Windows 7. Ich denke du wolltest wissen ob der Stick überhaupt
> funktioniert

Ich bin erstaunt, das der Stick unter Windows 7 läuft...

Ja, das wollte ich. Ich denke, das Problem liebt an fehlenden 
Programmen/ Libs unter Linux...

Unter folgenden Webseiten solltest Du Hilfe finden:

* http://ubuntu.frankenberger.at/Huawei_E220.html
* 
http://ubuntuusers.de/search/?query=huawei+e220&ar...

Amsonsten, Google :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.