mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega8 PORTB PB.7 PB.6 &PB.0


Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
ich hab mir ein stk500 und einen mega8 gekauft. hab ein bisschen 
rumgespiel und klappt soweit auch ganz gut. nur wenn ich den PortB 
verwende dann funkionieren die Ports PB.7, PB.6 und PB.0 nicht. verwende 
ich PortD klappt alles, also sind die leds in ordnung. Den Takt hab ich 
auch auf external clock umgestellt. kann mir einer sagen wieso ich die 
drei ports trotzdem net steuern kann. Jumper sind auf 
Standardeinstellung.
hab über die Forensuche schon viele gleiche beiträge gefunden, aber mit 
keiner Lösung bin ich zum ziel gekommen. danke
mfg max

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schonmal nachgeschaut was für Funktionen an den "nicht funktionierenden" 
Pins liegen?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PortB 7 und 6 sind bestimmt vom Quarz belegt. Schau mal auf dem STK500 
ob der OSCSEL Jumper sitzt.
und Portb0 ... keine Ahnung :)

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
6 und 7 sint xtal 1 und 2 sowie Tosc1 und 2 und PB.0 ist ICP1.
wie gesagt clock ist auf external geschalten. funktionerts deswegen 
net?? aber wenn ich den clock auf internal stelle gehts au net besser. 
aber was hat der PB.0 damit zu tun??
mfg

Autor: Herr Mueller (herrmueller)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Port B0 muss funktionieren. B6 und B7 sind Quarz Anschlüsse. Falls Du 
internen Takt verwendest, kannst Du die Ports auf dem STK500 an Port 
E/AUX  an XT1 und XT2 abgreifen.

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja des hab ich vorher wo gelesen.
aber PB.0 geht net!!!
ich weis das er eigentlich funktionieren sollte.
mfg

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>ja des hab ich vorher wo gelesen.
>aber PB.0 geht net!!!
>ich weis das er eigentlich funktionieren sollte.

Du hast jetzt also auf internen Takt gefused?
Dann gehen PB6 und PB7 jetzt?
Wenn du auf external Clock fused geht PB6 nicht.
Ohne externen Takt läuft dann das Programm nicht.
Wenn du auf external crystal fused gehen PB6 und 7 nicht.
Ohne Quarz läuft dann auch das ganze Programm nicht.
PB0 muss in allen Fällen mit entsprechender Beschaltung
(ext.Takt oder Quarz) funktionieren. Es sei denn dein Programm ist Müll.
Wie sieht das Programm aus?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.