mikrocontroller.net

Forum: PC Hard- und Software Schwarzer Bildschirn nach xorg.conf Modifikation


Autor: Linuxfan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute, vieleicht hat von euch jemand eine Idee warum mein 
Bildschirm nach der Modifikation der xorg.conf Konfigurationsdatei fürn 
X11 Sever beim Start einfach schwarz bleibt. Ich will Dualhead mit einer 
AGP Geforce 2MX und einer PCI Matrox Millenium MGA2064W einrichten. Mit 
der originalen xorg.conf arbeitet die Geforce 2 normal und er Bildchirm 
an welcher die Matrox Millenium hängt bleibt schwarz.

Modifiere ich die xorg.conf wie unten gezeigt, so bleiben beide 
Bildschirme schwarz. Es kommt kein Kommandozeilenmodus, wie jener der 
kommt, wenn man die xorg.conf falsch konfiguriert hat, der Bildchirm 
läuft zwar bleibt aber einfach schwarz.

Klammere ich die Section für die Matrox Millenium aus, so läuft nur der 
Bildschirm welcher an der Geforce hängt.

Wenn man die unten gezeigte xorg.conf benutzt so findet sich im 
/var/log/Xorg.0.log kein Hinweis auf eventuelle Fehlkonfiguration, habe 
die Datei nach einem Systemstart mit schwarzem Bildschirm mit Knoppix 
angeschaut.
# /.../
# SaX generated X11 config file
# Created on: 2009-10-24T14:11:24+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "freetype"
  Load         "dbe"
  Load         "dri"
  Load         "glx"
  Load         "extmod"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Logitech M-UV69a Optical Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor" #Monitor 0 IIjima vision Master Pro 451
  DisplaySize  380 290
  Identifier   "Monitor[0]"
  ModelName    "Vision Master 451"
  Option       "PreferredMode" "1600x1200"
  VendorName   "Ilyima"
  HorizSync    31-106
  VertRefresh  50-85
EndSection

Section "Monitor" #Monitor 1 Phillips 107E4
  DisplaySize  320 250
  Identifier   "Monitor[1]"
  ModelName    "Ph107E4"
  Option       "PreferredMode" "1024x768"
  VendorName   "Philips"
  HorizSync    31-80
  VertRefresh  50-75
EndSection

Section "Screen"    #Screen 0 IIjima vision Master Pro 451, Output from Nvidia Geforce 2MX Device 0
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Screen" #Screen 1 Phillips 107E4, Output from Matrox MGA2164W Millenium Device 1
  DefaultDepth 16
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "800x600" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "800x600" "640x480"
  EndSubSection
  Device       "Device[1]"
  Identifier   "Screen[1]"
  Monitor      "Monitor[1]"
EndSection


Section "Device" #Geforce 2MX on VGA Output 0
  BoardName    "GeForce2 MX/MX 400"
  BusID        "1:0:0" #PCI Slot 1, AGP is PCI extention
  Driver       "nv"    #Driver for most Nvidia graphic cards
  Identifier   "Device[0]"
  Screen       0       #VGA Output 0, !!!Not the Screen!!!
  VendorName   "NVidia"
EndSection

Section "Device" #Matrox MGA2064W Millenium on Scren 2
  BoardName    "MGA2064W"
  BusID        "2:7:0" #PCI Slot 2
  Driver       "mga"   #Driver for most Matrox graphic cards
  Identifier   "Device[1]"
  VendorName   "Matrox"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       0 "Screen[0]" 0 0                  #Output on Screen 0, identifier of Scrren 0
  Screen       1 "Screen[1]" LeftOf "Screen[0]"   #Output on Screen 1, identifier of Scrren 0
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "Composite" "off"
EndSection


Vieleicht hat jemand eine gute Idee, ich bin ein wenig am verzeifeln, 
mein anderer Dualhead Rechner mit Matrox G400 lief nach dem 2.versuch im 
Dualhead Mode.

Autor: Basti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaut gut aus

1) Was sagt die /var/log/x.log?

wenns nichts hilft, schummel ich bei der xorg.conf immer. Lad dir ne 
Opensuse Live-CD, fahr sie hoch, geh auf die console und beende xdm . 
dan startest du sax2. mit diesem tool kannst du so ziemlich JEDE option 
ändern (xorg.conf)

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie vertragen sich die angegebenen (und sich unterscheidenden) 
DefaultDepth-Werte für die Geräte? Abgesehen davon würde ich die Finger 
von der xorg.conf lassen - die ist hierzuworkstation einfach zu 
unflexibel - und stattdessen mit xrandr rumspielen :-) Einen Versuch 
wärs zumindest wert.

Autor: Linuxfan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es läuft immer noch nicht. Habe es auch schon mit dem "vesa" Treiber für 
die Matrox Millenium versucht, resultiert ebenfalls in schwarzem 
Bildschirm.
Was bedeutet eigentlich die "Screen 0..." und "Screen 1..." in der 
"ServerLayout" Section?
Könnte es eventuell daran liegen, dass sich die beiden Treiber nicht 
vertragen und der Nvidia Treiber den Matroxtreiber und sich selbst 
abschiesst? Nvidia Treiber sind doch soweit ich weiss allgemein als 
close source und mies bekant.

Autor: Linuxfan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man beide Grafikkarten mit dem "vesa" Treiber ansteuert, so hat der 
Geforce-Bildschirm einen ca 10 Pixel breiten vertikalen Strich welcher 
seine Farbe ändert, wenn z.B. enter ddrückt und somit blind ein Programm 
startet oder mit Alt-F1 die Startleist öffnet.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.