mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Arm7 (Usbizi) über SPI LCD


Autor: Michael Krentscher (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bräuchte mal Hilfe bei der Verkabelung. An dem USBizi (Arm7) will 
ich ein LCD Display über SPI Anschließen. Hintergund ist schon mal weiß 
;-). Ist das so richtg ?

1,4,5,6,42,43,47,50 auf Ground
48,49 10 Volt Backlight OK.
44,45 auf 3,3 Volt

So jetzt das SPI Interface

PS0-PS3 auf High (SPI 4 Wire)


USBizi (H2) -> LCD

MOSI0 - SDA
MISO0 - SDO
SSEL0 - CS
SCK0 - SCL

GPIO (E39) - Reset
GPIO (E38) - Serial Data/Command

Gruß Michael

Autor: Michael Krentscher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe jetzt das Programm umgeschrieben auf C#. Leider tut sich am Display 
nicht besonders viel.

Hat jemand dieses Display im Einsatz und kann mir das Verhalten bei 
einem Reset mitteilen ?. So das ich wenigstens weiß ob ich es richtig 
Angeschlossen habe ??

Gruß Michael

Autor: Michael Krentscher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ab und an sehe ich auf dem Display einen 1/3 breitem Streifen mit allen 
Farben. Ich denke das Timing stimmt noch nicht so ganz.

Trotzdem wäre es nett wenn sich jemand mit dem gleichen Display mal 
melden würde wegen der Pinbelegung.

Gruß Michael

Autor: Michael Krentscher (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat doch etwas länger gedauert. Die Pinbelegung stimmt jetzt und ich 
kann das Display Addressieren.

Erstmal danke für die Hilfe bis jetzt. Gibt es da draussen noch irgend 
jemand anderen der ein solches Display ansteuert ?

Ein paar Fragen habe ich nämlich noch und die Hoffnung stirbt auch hier 
zuletzt ?

Wie siehts aus mit Zeichensätzen ?! Pixel ich mir die jetzt selber ?! 
Gib's irgendwo noch welche ??

Das gesammte einfärben dauert gefühlte 30 Sekunden... Ist das etwa alles 
:-(

Das wird noch ein Stück Arbeit

Gruß Michael

Autor: Michael Krentscher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

so eine einfache Schrift habe ich jetzt mal getestet. Funktioniert 
soweit. Allerdings nur Senkrecht ;-).

Immer noch sehr langsam...

Bin ich hier eigentlich im falschen Board ? Oder juckt das Display 
keinem.

Gruß Michael

Autor: Michael Krentscher (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

soderle. Habe mein Ziel erreicht. Durch dieses Forum... ? Durch die 
Antworten... ? Ich denke nicht...... !

Eigentlich schade...  Dabei dachte ich: Ist ein Forum eine Art moderner 
Gedankenaustausch.

Gruß und bis zum nächsten Mal..
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.