mikrocontroller.net

Forum: PC-Programmierung Installation von Eclipse C/C++


Autor: NewUser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte auf Ubuntu die Eclipse Entwicklungsumgebung für C/C++ 
installieren. Brauche ich da zunächst eine Java Laufzeitumgebung?
Wie muss die Installation von Eclipse C/C++ durchgeführt werden ?

Autor: Stephan M. (stephanm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NewUser schrieb:
> ich möchte auf Ubuntu die Eclipse Entwicklungsumgebung für C/C++
> installieren. Brauche ich da zunächst eine Java Laufzeitumgebung?

Ja, für Eclipse brauchst Du immer eine Java Laufzeitumgebung (JRE), da 
Eclipse selbst "ein Java-Programm" ist.

> Wie muss die Installation von Eclipse C/C++ durchgeführt werden ?

Entweder: Unter http://www.eclipse.org/downloads/ kannst Du "Eclipse IDE 
for C/C++ Developers (79 MB)" herunterladen. Das ist eine 
Eclipse-Distribution, die die für C/C++-Entwickler benötigten 
Komponenten bereits enthält.

Oder: Du lädst Dir die "klassische" Eclipse-Distribution herunter, das 
ist dann z.B. "Eclipse IDE for Java EE Developers (188 MB)" oder 
"Eclipse IDE for Java Developers (92 MB)" und installierst CDT und die 
benötigten Abhängigkeiten manuell. Wie das geht ist auf der Projektseite 
des CDT beschrieben. Dank des Eclipse Update Managers ist das i.A. kein 
Problem.

Stephan

Autor: NewUser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese beiden Dateien habe ich bereits heruntergeladen.

--> eclipse-cpp-galileo-SR1-linux-gtk-x86_64.tar
--> eclipse-java-galileo-SR1-linux-gtk-x86_64.tar

Wie muss ich nun die Java Laufzeitumgebung mit Hilfe des Terminals 
installieren?

Autor: Stephan M. (stephanm)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NewUser schrieb:
> Diese beiden Dateien habe ich bereits heruntergeladen.
> --> eclipse-cpp-galileo-SR1-linux-gtk-x86_64.tar
> --> eclipse-java-galileo-SR1-linux-gtk-x86_64.tar

Warum beide?

> Wie muss ich nun die Java Laufzeitumgebung mit Hilfe des Terminals
> installieren?

Da gibts doch bestimmt ein Ubuntu-Paket für. Wenn Du nicht weist wie das 
geht dann ab ins Ubuntu-Forum :-)

Manuelle Installation (Obacht, benötigt etwas Fachwissen bzgl. Linux und 
JRE!):

zip <Dateiname> && JAVA_HOME=${PWD}/java_X_Y_Z \
${PATH_TO_ECLIPSE}/eclipse ${ECLIPSE_ARGS}

Stephan

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NewUser schrieb:
> Wie muss ich nun die Java Laufzeitumgebung mit Hilfe des Terminals
> installieren?
http://www.google.de/#hl=de&source=hp&q=ubuntu+jav...

Dann einfach entpacken und Eclipse starten...

Autor: ... ... (docean) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gibts eclipse nicht als Paket dabei? ich mein da war mal was...

Autor: NewUser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab die Datei "eclipse-java-galileo-SR1-linux-gtk-x86_64.tar" 
entpackt und auf dem Desktop abgelegt. Nun wollte ich Java mit folgender 
Kommandozeile starten:

sudo apt-get install eclipse

Dies funktioniert nicht. Ich verstehe nicht warum.

Autor: NewUser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich muss noch dazu sagen, dass das Internet unter Ubuntu nicht 
funktioniert.

Autor: R. Freitag (rfr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was heisst 'Dies funktioniert nicht. Ich verstehe nicht warum.' ?
Fehlermeldung?


Gruss

Robert

Autor: NewUser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eingabe: sudo apt-get install eclipse

Meldungen:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Reading state information... Fertig
E: Konnte Paket eclipse nicht finden
user@user:~/Desktop/eclipse_java$
user@user:~/Desktop/eclipse_java$

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du brauchst eclipse nicht "installieren"...
Du mußt java installieren (ohne Internet etwas doof, wieso läuft das bei 
dir nicht) dann kannst du es einfach aus dem entpackten Ordner starten.

Autor: Link zu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Damit du das hingekommst musst du mehrere Sachen vorab erledigen:
-Internet zum 'Laufen bekommen'.
-sudo apt-cache search eclipse
-Die Ausgabe des obigen Befehls lesen, evtl. gibt bei Ubuntu schon ein
 CDT-Plugin im Paketmanagment. Siehe auch [1].
-sudo apt-get install eclipse und evtl. das CDT-Plugin dazu.
-Wenn es das CDT-Plugin nicht gibt im Paketmanagment, dann musst du es
 aus Eclipse heraus installieren. Siehe auch [1].


[1] 
http://www.wiki.elektronik-projekt.de/mikrocontrol...

*Merke*: Unter Linux gibt praktisch immer ein Paketmanagement, nutze 
es, es nimmt dir viel Arbeit ab!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.