mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AT90S2313 Startproblem


Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe ein kleines problem mit einem AT90S2313 dinosaurier. das ding 
scheint aus irgendeinem grund nicht anzulaufen obwohl flash write und 
flash verify wunderbar klappt. der mag nichtmal eine LED zum leuchten 
bringen selbst wenn der gesamte port als ausgang programmiert wird.

meine frage wäre ob ich davon ausgehen kann, daß der quarzoszillator 
(4MHz) problemlos angelaufen ist wenn ich den flash lesen und schreiben 
kann?

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
okay selber erwischt: quarz defekt... :-(( ausgetauscht und LED geht an.

merke: zumindest beim AT90S2313 braucht man keinen voll funktionierenden 
oszillator um ihn zu programmieren.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.