mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schmitttrigger bei PIC18LF458


Autor: Juergen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

folgendes Problem der µC erkennt an RD1-RD3 keine Signale. Als high 
liegen 3,1 Volt an. Die Versorgungsspannung beträgt 3,3V. Das PortD 
Register bleibt auf bit 0-3 immer auf 0 gesetzt.

TRISD = 0b00001111;  
TRISEbits.PSPMODE = 0;


Das ist der Code für die Initialisierung. Hab ich da noch irgend ein
Register vergessen ?

Danke

Jürgen

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Bleibt immer null.
Kommt denn ein CS und Write von deinem Host? Sonst werden die Daten 
sicher nicht übernommen !

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.