mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit dem PowerSwitch USB


Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, Leute!

Ich habe eine Platine nach 
http://www.obdev.at/products/vusb/powerswitch.html gemacht.
Ich nutze einen ATTiny2313.

Das Ding scheint nicht tot zu sein (es ist schon was!), aber richtig 
funktioniert die Schaltung nicht...

Ich habe ein Testprogramm gebastelt, mit dem ich den Relais (und die 
dazu gehörigen LED) an dauern ein- und ausschalte. Das funktioniert.

Wenn ich aber das Programm von obdev.at nutze funktioniert das ganze 
nicht.
Ich erkläre:

wenn ich die Platine mit meinem PC verbide (über USB-Kabel) bekomme ich 
diese Fehlermeldung in den Log:
Dec 20 13:44:27 robot kernel: [ 3740.559456] usb 1-1: new low speed USB device using uhci_hcd and address 62
Dec 20 13:44:27 robot kernel: [ 3740.643837] usb 1-1: device descriptor read/64, error -71
Dec 20 13:44:27 robot kernel: [ 3740.768980] usb 1-1: device descriptor read/64, error -71
Dec 20 13:44:27 robot kernel: [ 3740.898448] usb 1-1: new low speed USB device using uhci_hcd and address 63
Dec 20 13:44:27 robot kernel: [ 3740.961819] usb 1-1: device descriptor read/64, error -71
Dec 20 13:44:28 robot kernel: [ 3741.092400] usb 1-1: device descriptor read/64, error -71
Dec 20 13:44:28 robot kernel: [ 3741.202729] usb 1-1: new low speed USB device using uhci_hcd and address 64
Dec 20 13:44:28 robot kernel: [ 3741.430743] usb 1-1: device not accepting address 64, error -71
Dec 20 13:44:28 robot kernel: [ 3741.492507] usb 1-1: new low speed USB device using uhci_hcd and address 65
Dec 20 13:44:29 robot kernel: [ 3741.704459] usb 1-1: device not accepting address 65, error -71

Und, selbstverständlich, ist kein USB-Gerät zu sehen.

Ich habe alle Kontakte geprüft, und sieht es in Ordnung aus.
Ich weiß wirklich nicht, was es sein kann... Hat jemand eine Idee?

Danke
Luca Bertoncello

Autor: Potter S. (potter68)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Luca,

wenn sich das USB-Gerät nicht ordentlich am PC anmeldet, dann ist 
entweder ein Fehler in Deiner Schaltung oder Deine Anpassung des 
USB-Treibers (falls Du die Firmware von OBDEV geändert hast) ist 
fehlerhaft.

Am besten Du prüfst mal Deine Schaltung auf Kurzschlüsse und falsche 
Pin-Belegung. Mit welcher Frequenz läuft Dein Controller?

Hier ein paar Tipps für das Layout: http://vusb.wikidot.com/hardware

Gruß Potter

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ralf Handrich schrieb:

> wenn sich das USB-Gerät nicht ordentlich am PC anmeldet, dann ist
> entweder ein Fehler in Deiner Schaltung oder Deine Anpassung des
> USB-Treibers (falls Du die Firmware von OBDEV geändert hast) ist
> fehlerhaft.
>
> Am besten Du prüfst mal Deine Schaltung auf Kurzschlüsse und falsche
> Pin-Belegung. Mit welcher Frequenz läuft Dein Controller?
>
> Hier ein paar Tipps für das Layout: http://vusb.wikidot.com/hardware

Hallo, Ralf!

Besten Dank für deine Antwort!
Ich glaube daß das Problem bei der Spannungsregler ist!
Ich habe einen µA7805 (empfohlen von einem Freund) der mir 5V gibt, ich 
sehe aber, daß ich eigentlich 3.3V geben soll...
Leider finde ich nirgendwo einen LE35CZ (wie in dem Schema von obdev.at 
geschrieben ist).

Kannst du mir was anderes empfehlen?

Danke!
Luca Bertoncello

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.