mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit ATMega48 programmieren


Autor: Raphael F. (erdbewohner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich habe mir ein völlig simples Programmierboard für ATMega32/16 
zusammengelötet und zwar habe ich einfach die Pins am Programmierstecker 
mit den  entsprechenden Pins an der Chip-halterung verbunden, den 10kOhm 
Widerstand am Reset-VCC habe ich auch verwendet. Es hat funktioniert!
Nun habe ich das gleiche für einen ATMega48/8/88/... gelötet, anfänglich 
mit den beiden Entstörkondensatoren und es hat nicht funktioniert. Da 
dachte ich, vielleicht habe ich die Kondensatoren beim Löten verbrannt 
und habe sie ausgelötet, es funktionierte wieder nicht. Die Schaltung 
habe ich mehrfach  überprüft. Ich verwende AVRISP mit AVRStudio 4, die 
Frequenz habe ich auf 57,6 kHz eingestellt. Immer wenn ich die Signatur 
auslesen will, erscheint  "Entring programming mode.. FAILED!" Wo liegt 
das problem???
Danke für jede Hilfe!!
lg Erdbewohner

Autor: Oliver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bauteil 42 ist verkehrt gepolt.

Oliver

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.