mikrocontroller.net

Forum: Compiler & IDEs Problem bei externem Interrupt und ADW


Autor: Gandi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich benutze den externen Interrupt als Nulldurchgangserkenner laut einer 
Anleitung von ATMEL. Ich bekomme einen Interrupt am Anfang der Periode 
und möchte dann 50 Messpunkte aufnehmen, welche von einem Timer 
gesteuert werden.
Problem: Anstelle eines Interrupts (funktioniert ohne ADW) kommen 
hintereinander 2 Interrupt wenn der ADW aktiviert ist?!?!
INT2 bei steigender Flanke mit Interrupt.
ADW ohne Prescaler, 8 bit, 5V.
Timer1, CTC Mode, Prescaler 64.

irgendwelche Ratschläge?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.