mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik [ARM9] Framebuffer Problem


Autor: Andreas Auer (Firma: Embedded Microtec) (andi) Flattr this
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich hab hier ein Embedded Linux Board mit einer Davinci CPU (DM6446) von 
TI. Das Board ist etwas abgespeckter als das EVM von TI, aber ansonsten 
sehr ähnlich von den Devices her. Ich hab momentan den Kernel 2.6.32 
laufen.

Das Problem das ich jetzt habe, ist, dass der Framebuffer ansich 
funktioniert, jedoch das Bild etwas komisch aussieht. In den Anhang hab 
ich mal 2 Screenshots gepackt. das eine Bild (test_image.jpeg) ist das 
Originalbild. Der 2. Screenshot (test_image_dm6446.jpeg) ist das 
ausgegebene Bild vom DM6446 Prozessor. Der Prozessor gibt das Bild über 
einen Composite Ausgang auf den Fernseher im PAL Format aus.
Die Bilder sehen ja aus als wären die Halbbilder versetzt. Außerdem 
flimmert das Bild auf dem Fernseher sehr stark in vertikaler Richtung.

Weiß jemand an was das liegen kann (generell was das Problem sein 
könnte)? Vom Prozessor her kann man auf jedenfall einstellen wieviele 
Zeilen er pro Halbbild zeichnet (312,5 oder 312 oder 313). Kann es daran 
liegen??

Schonmal danke,
Andreas

Autor: Andreas Auer (Firma: Embedded Microtec) (andi) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner eine Idee was da falsch laufen könnte?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.