mikrocontroller.net

Forum: PC Hard- und Software Win7 64bit - Classpnp.sys USB schaltet ab


Autor: Pascal H. (pase-h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich habe ein großes Problem!
Heute Nachmittag war mir langweilig, und wollte endlich mal mein 
Atmegaboard flashen. Also den selbstgebauten Programmer(USBASP - Ging 
zuvor auf Vista schonmal) in den USB-port gesteckt, der Treiber wird 
installiert, und als die Installation fertig war, geht auf einal die 
Maus und meine Tastatur aus! Also ein Neustart und Freu: Maus und 
Tastatur gehen wieder. Dann beim Login Bildschirm die Enttäuschung: Maus 
und Tastatur sind wieder aus.
-> Abgesicherter Modus: Maus und Tastatur gehen dann aus, wenn die 
Classpnp.sys geladen wird(hab schon gemessen, Die Spannung bleibt 
konstant auf 5V am USB-> Es werden anscheinend nur die Datenleitungen 
abgeschaltet - Und Alle LED's gehen aus).
Da ich jetzt nurnoch meine 2. Partition habe(auch Win7) kann ich die 
Datei nun auch nicht mit der funktionierenden überschreiben/ersetzen, da 
ich laut Windows erst die Rechte vom TrustedInstaller erhalten muss!
Über die Windows DVD kann ich auch nichts machen, da meine Partition mit 
der defekten Datei nicht anwählbar ist.

Was ich bereits probiert hab:
Die pcmcia.sys in pcmcia.sys.old umbenennen
Div. Einstellungen im Bios ändern
Die Classpnp.sys Löschen/ersetzen
Startuprepair benutzen

Mein System:
Windows 7 x64
Asus P5k
Core2duo mit 2*3Ghz
Nvidia 285GTX
8Gb DDR2 Ram
500Gb Festplatte
IDE DVD Laufwerk/Brenner

Hoffe ihr könnt mir schnell helfen!
Schonmal Danke im vorraus
Mfg Pase-h

Autor: Chris R. (hownottobeseen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schonmal die Systemwiederherstellung (!= Repairinstall) probiert?
Wenn du Glück hattest wurde bei der Treiberinstallation ein 
Wiederherstellungspunkt gesetzt.

Autor: Pascal H. (pase-h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist ja das Problem:
wenn ich von der Windows DVD Boote und das Sytem auswähle kommt immer 
die Meldung, dass das Betriebssystem eine Falsche Version ist.
Fazit:
Ich kann nicht mal mehr über die Win DVD die Platte Reparieren.
trotzdem danke für die Hilfe!;-)
:Hinsetzundwarteaufneuehilfe:
Mfg Pase

PS: Meine Idee wäre, eine Bootbare LinuxDVD zu machen, und die defekte 
Datei zu ersetzen?
PPS: Falls es Hilft: Ich benutze Win7 Ultimate x64

Autor: Arc Net (arc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pascal Haury schrieb:
> Das ist ja das Problem:
> wenn ich von der Windows DVD Boote und das Sytem auswähle kommt immer
> die Meldung, dass das Betriebssystem eine Falsche Version ist.

Sicher das das die richtige DVD ist?

> Fazit:
> Ich kann nicht mal mehr über die Win DVD die Platte Reparieren.
> trotzdem danke für die Hilfe!;-)
> :Hinsetzundwarteaufneuehilfe:
> Mfg Pase
>
> PS: Meine Idee wäre, eine Bootbare LinuxDVD zu machen, und die defekte
> Datei zu ersetzen?
> PPS: Falls es Hilft: Ich benutze Win7 Ultimate x64

Funktioniert F8 beim Booten noch?
D.h. weder Last Known Good noch Disable Driver Signature Enforcement 
bringen irgendetwas?
Letzteres dürfte wohl das Problem sein, da die libusb Treiber vom USB 
ASP nur dann funktionieren,  wenn man dies bei jedem Boot erneut zulässt 
(s.u.), ansonsten blockiert der Treiber u.U. alle anderen USB-Treiber.
Signierte libusb Treiber gibt es z.B. auf
http://www.pruftechnik.com/condition-monitoring/su...

Aus der Readme vom USB ASP
"For Windows Vista X64 and Windows 7 X64:

First enable the "testsigning" mode,
manually by selecting Start->All Programs->Accessories->Command Prompt,
right-clicking on it, selecting "Run as administrator"
and typing the following command:
>> bcdedit -set TESTSIGNING ON

To disable testsigning mode, you need to run the following command:
>> bcdedit -set TESTSIGNING OFF

Note that you will need to restart your computer for this change to take 
effect."

Autor: Pascal H. (pase-h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Arc Net schrieb:
> Funktioniert F8 beim Booten noch?

Vielen Dank für den Tipp!!
Habs endlich Geschafft!
Mit Disable Driver Signature Enhancement und Last known good 
Configurations
hats dann wieder funktioniert!!!
VIELEN Dank Arc Net!

MFG Pase

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.