mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme bei Programmierung mit AVR Studio 4.18 SP2


Autor: cellcon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

ich habe seit ich neulich von Vista (32 Bit) auf Windows 7 (32 und 64 
Bit) umgestiegen bin folgendes Problem:

Ich kann keinen µC mehr programmieren. Ich besitze einen AVR Dragon und 
einen AVR ISPmkII. Programmieren will ich neben eigenen Schaltungen 
einen AVR Butterfly.

Das hat unter Vista alles noch problemlos funktioniert, ich habe seitdem 
nichts geändert - keine Fuses und nichts an den Schaltungen.

Ich erhalte aber, egal was ich mache die Fehlermeldungen, die im Anhang 
sind. Sie unterscheiden sich je nach verwendeter Programmierungsfrequenz 
(über bzw. unter 101Hz).

Ich habe alle Frequenzen ausprobiert und keine Ahnung mehr, was es sein 
kann. Mittlerweile habe ich unzählige Stunden darein gesteckt und auch 
hier im Forum schon so manches gelesen

Hat irgendjemand von euch eine Ahnung, was das sein kann?

Vielen Dank!!!

Gruß
Cellcon

Autor: Hans_Dampf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also ich hab auf meinem Laptop (Windows 7 - 32 Bit; Core 2 Duo) das 
AVR-Studio 4.18.692 (ISPmkII USB) und es geht ohne Probleme.

* Schon eine Neuinstallation versucht?
* Bekommst du bei deinem ISPmkII irgendwelche optischen Anzeigen.

Viel Glück schonmal.

MfG

Autor: cellcon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hans_Dampf,

eine Neuinstallation habe ich schon 3 mal hinter mir, der mkII zeigt bei 
niedrigen Frequenzen oranges blinken und bei höheren Frequenzen oranges 
Standlich nach kurzem blinken an.

Das geht dann aber wieder in grünes / rotes leuchten über (je nachdem 
was ich grade probiere) sobald die Fehlermeldungen bestätigt wurden.

Cellcon

Autor: cellcon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es kann aber auch passieren, dass der mkII im orange blinkenden Modus 
verbleibt.

Das Studio 4.17 funktioniert übrigens auch nicht besser.

Autor: Wayne Monga (vibra)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sorry

Win 7 32 Bit, AVR Studio 4.18 SP1, Dragon , STK500 alles geht ohne 
Probleme .

mfg

Autor: cellcon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt heraus gefunden, dass es Probleme mit dem Butterfly in 
Kombination mit dem ISPmkII gibt. Leider habe ich die relevanten Seiten 
erst gefunden, nachdem ich "orange blinking" meinen Suchbegriffen 
hinzugefügt habe.

Ohne es einmal ins Forum zu schreiben, wäre ich da nicht drauf gekommen.

Also vielen Dank Hans_Dampf! :-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.