mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik EEPROM Fehler


Autor: Dan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
hab ein Problem beim Anlegen eines Arrays im EEPROM beim Atmega8.
Das Array anlegen an sich ist nicht das Problem, sondern die Größe.
Ich lege das Array folgendermasen an:
uint16_t daten[181] EEMEM; in diesem Fall 362Byte groß,funktioniert 
noch.
Sobald ich aber über 362Byte komme also zum Beispiel uint16_t daten[182] 
EEMEM, bekomme ich beim brennen im myAVR ProgTool die Meldung: "Fehler 
beim Schreiben der Daten." und der Vorgang wird abgebrochen.
Ist das Problem bekannt oder hab ich eine Einstellung vergessen?

Gruß Dan

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Hast du noch andere Sachen im EEPROM?

MfG Spess

Autor: Dan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi.
Nicht dass ich wüsste.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.