mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LPC2468 - Ports reagieren nicht


Autor: Frank Bär (f-baer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

wiedermal mein heißgeliebter 2468, dieses Mal möchte er keine Register 
schreiben, dementsprechend kann ich die Ports 3 und 4 nur sporadisch 
beeinflussen. Nachdem das Problem (wie auch immer - auf einmal gings) 
auf Port3 zumindest soweit verschwunden ist, als dass ich die benötigten 
Pins setzen kann, kommt mir das selbe Problem jetzt bei Port4 entgegen.

Schreiben auf FIO4MASK bringt kein Ergebnis, wenn ich mir den 
Speicherinhalt so betrachte, dann würfelt er den wohl beim Reset aus. 
Mir gehen langsam die Ideen aus. Im Disassembly steht soweit alles 
korrekt, nur der Speicherinhalt, den mir der Debugger (HITOP 5.3x) 
ausspuckt, ist nicht ganz das, was ich mir erwarte.

Ich bin für jede Anregung überaus dankbar!

Gruß,
Frank

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.