mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik PWM Bug im Simulator


Autor: Sebastian Thiess (labude)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich versuch gerade den 16 Bit Timer eines ATtiny2313 im Simulator zu 
testen, dabei nervt mich der (bekannte) Bug des AVR Studio Simulators, 
dass der fast PWM-Mode nicht richtig erkannt wird. Nun dachte ich gibt 
es vielleicht einen anderen Chip, meinetwegen einen ATmega(...), bei dem 
der Simulator fehlerfrei läuft und auf dem ich ersatzweise das Programm 
testen könnte? Weiss da jemand mehr?

Danke!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.