mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit ATMEGA8


Autor: zickzack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo!

ich habe den USB-IR-Receiver von portisch nachgebaut.
Beitrag "Re: USB IR Remote Receiver (V-USB + IRMP)"

die schaltung habe ich schon gelötet. wenn ich den receiver per usb
anschließe, wird auch schon mal ein unbekanntes usb-gerät angezeigt. der
usb standard scheint also schon mal zu stimmen.
nun habe ich versucht den receiver per ponyprog2000 zu programmieren.
ich habe die anleitung von portisch schritt für schritt befolgt. beim
auslesen der fuse-bits schon das erste prob: anfangs hat er immer
"missing device" gemeldet; nach ein paar mal "retry" hat er aber die
bits ausgelesen. ich habe die bits richtig gesetzt und dann "write"
geklickt. das hat dann auch funktioniert. jedenfalls kam keine
fehlermeldung.
danach habe ich auf "write all" für das programm geklickt. anfangs ging
es wieder nicht, aber nach ein paar mal "retry" hat es funktioniert und
er hat geschrieben, verifiziert,...und dann kam "write failed".

ich habe den receiver nun schon x mal abgesteckt, den reset-pin gesetzt
usw, aber er reagiert nun nicht mehr. wenn ich bei den fuse-bits auf
"read" klicke, kommt immer "missing device".

calibration im ponyprog habe ich durchgeführt.

eventuell wurden die fuse-bits durch ein verbindungsproblem nicht ganz 
gesetzt?!? kann ich die wieder auf auslieferungszustand zurück setzen?

was könnte da nicht stimmen? wäre für ein paar tipps wirklich sehr
dankbar!

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einfach nur halb so oft Hilfe schreien,
du hast dieselbe Frage schon im Thread
"Re: USB IR Remote Receiver (V-USB + IRMP)"
gestellt.

Autor: zickzack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und bisher hat sich das problem noch nicht gelöst...

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na dann mach doch am besten noch einen Thread auf!

Autor: zickzack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich denke, dass in einem problemspezifischen thread eher jemand rein 
schaut der sich mit dem problem auskennt, als in einem thread um einen 
ir-receiver.

jetzt schluss mit eurem spam und bitte nur noch hilfreiche posts!

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Problem mit ATMEGA8" nennst du problemspezifisch??
Bitte??

Die Lösung findest du mit <1min suchen.
Viel Spaß dabei.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.