mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik atxmega avrstudio 4.18


Autor: Byteschieber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich habe Erfahrung mit verschiedenen ATMegas und möchte mich jetzt am 
ATXmega versuchen.
Habe mit AVR-Studio ( neuste Version ) ein Projekt in "C" erstellt und 
zu compilieren versucht, ich bekomme folgende Fehlermeldung:

../main.c:1: error: MCU 'atxmega128a1' supported for assembler only

Kann mir jemand erklären woran das liegt... hab schon gegoogelt!!!

Viele Grüße

Wolfgang

Autor: RudiBe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du vorher mit AVR-Studio nen ATmega mit C erfolgreich beschrieben?
Falls nein bzw. nicht versucht fehlt aktuelle Version von WinAVR.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.