mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LPC2129 - startup landet im Undef_Handler


Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe ein sehr zumindest für mich komisches Problem.

Und zwar hab ich eine Software für den LPC2129 (selbstentwickeltes 
Board) geschrieben.
Diese kann ich mit dem Keil ULinkMe-Debugger auch Problemlos draufladen 
und auch starten bzw. ausführen. Sie funktioniert auch soweit.

Wenn ich den Code auch mit uvision auch nur lade, ohne in die Debug 
Oberfläche zu gehen, dann den Debugger abstecke, dann läuft sie auch 
ganz normal.

Wenn ich jetzt allerdings den Strom vom Board nehme und dann wieder 
anlege, dann startet er nicht wie er soll, sondern ladet im 
Undef_Handler. (Das hab ich nach einigem rumprobieren rausgefunden)

Jetzt stellt sich für mich die große Frage, wieso?
Hat jemand ne Idee?

Danke im Voraus.

Gruß j

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.