mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LWIP UDP Problem


Autor: LWIP (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bin gerade an der Programmierung eines LM3S9B96. Ich versuche 
aufbauend auf dem LWIP Stack einen Port zu öffnen. Leider kommt bei der 
Compilierung dann der Fehler in Datei udp.c:291:58: macro "recv" passed 
5 Arguments, but takes just 4.
Das Problem ist, dass dies eine eingebundene Datei ist, die mit mittels 
Stellarisware zur Verfügung gestellt wird. Bei anderen Beispielprogramen 
wird die Datei ohne Probleme  compiliert. Da mir langsam die Ideen 
ausgehen wollte ich nun mal fragen, ob hier jemand schon mal das gleich 
oder zumindest ein ähnliches Problem hatte, und mir irgendwelche 
lösungsbringenden Ratschläge geben kann.
Danke schonmal für eure Hilfe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.