mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Radig Web Server Telnetport


Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
ich experimentiere mit dem Pollin AVR NET-IO herum und habe eine Frage.
Telnet funktioniert damit schön (Code von Ulrich Radig heruntergeladen, 
aktuelle Version). Wenn ich aber einen anderen Port nutzen möchte (ich 
will da etwas spezielles stricken) so meldet sich der WebServer erst 
nach etwa 3 Sekunden mit seiner Meldung "Start Telnet Server". Mit dem 
Default Port 23 gibt es da keine Verzögerung. Habe den Port nur in der 
Telnet.h geändert:

#define TELNET_APP_PORT 23  //Telnet port

Habe mal 25 versucht (SMTP) oder 50, es geht nur auf 23 ohne 
Verzögerung. Meine Nachforschungen haben ergeben, dass bei der 
Verzögerung die Funktion tcp_timer_call in stack.c aufgerufen wird. Das 
braucht anscheinend etwas Zeit, dann klappt es.
Danach ist alles wie normal, nur die erste Willkommenmeldung dauert 
etwas.

Kann mir das einer erklären? Woran liegt das?

Bin für jeden Hinweis dankbar, vielleicht probiert es mal jemand.

Wünsche ein schönes Wochenende..

Thomas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.