mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 verbindet nicht mehr


Autor: Patrick K. (unknown_artist)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!


Ich schaffe keine Verbindung mehr zum STK500. Urplötzlich. Heute mittag 
konnte ich damit noch ganz normal einen ATmega8 programmieren, dann hab 
ich es nichteinmal mehr angefasst, und als ich wieder verbinden wollte 
ging es nichtmehr.

Seitdem hat sich nichts geändert, weder durch einen Neustart, einem 
umdefinieren der COM-Ports, einem neuinstallieren der ExpressCard 
(OXPCIe952 Chipset - also "echter" Com-port), einem neuinstallieren des 
AVR-Sudios bis Build 715 (SP3).

Wenn ich Pin2 und 3 an dem D9-Stecker brücke und mit hterm ein Zeichen 
sende bekomme ich es zurück, der COM-Port scheint also zu funktionieren. 
Der Gerätemanager behauptet auch, das Gerät liefe "einwandfrei". 
(Achja, läuft Win7 Professional, 32bit)

Statusleuchte am STK leuchtet grün, die Versorgungsspannung ist im 
angegebenen Bereich, alle jumper sind korrekt, das Kabel hängt am RS232 
CTRL nicht am Spare. Kabel hab ich auch schon ausgetauscht.

Ich vermute fast, irgendwas belegt mir den COM-Port und ich schaff es 
nicht das Ding freizugeben, ist ja auch beschissen(Entschuldigt) dass 
AVR-STudio nur bis COM8 unterstützt.

Ach ja mit BASCOM-AVR (Demo) und Ponyprog hab ich auch keine Verbindung 
erhalten, aber das heißt nichts, ich hab nämlich keine Ahnung wie man 
die überhaupt einstellt.


Hat jemand noch ne Idee woran das liegen könnte?


Vielen Dank und Grüße,

Patrick

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.