mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FT2232C Problem mit Data Out


Autor: Stefan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich möchte an einem FT2232C einen ADC mit SPI-Schnittstelle
betreiben. Programmiert wird in Labview mit der FTDI-DLL.
Die Initialisierung des MPSSE-Modus scheint zu funktionieren.
Bei der Ausgabe eines Bytes sehe ich zwar das Clocksignal
(angehängtes Oszillogramm, Kanal 1), die Datenleitung DO
(Pin 23, Kanal 2) springt jedoch konstant auf 1, obwohl ich
z. B. 00110011b ausgebe. Der DO-Pin habe ich als Ausgang
definiert.
Weiß jemand, woran das liegen könnte, oder ist vielleicht
der Chip defekt.

Vielen Dank im Voraus,

Stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.