mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega644 in EEPROM speichern


Autor: Tony (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
bevor ich mit den codeschnipseln anfange möchte ich mal erklären worum 
es geht.
Ich baue mit meinem Chef eine Art kleine Haussteuerung und habe für Ihn 
bereits ein 2. Seite auf dem Webserver geschrieben.

Funktionieren tut sie im Moment derweil das sie alle Daten die in den 
definitionen angegeben sind und alle Sensoren (Temperatur + Licht) 
ausgibt. Die Sache ist das ebenfalls Werte im Eeprom gespeichert werden 
sollen.
also habe ich

"Sensor" - "Aktueller Wert" - "Gespeicherter Wert" - "Textfeld für 
speicherung"

in dieser art die Seite programmiert. Mein Problem im moment besteht 
darin das er zwar alles auslesen kann ... und auch etwas speichert ... 
aber anscheind was falsches und dadurch wird evtl. das system gecrashed.

eingang:
 void var_in_eeprom () //Schaltwerte in eeprom aus RAM schreiben
{
  schaltwerte_geaendert = 0;
  //int16_t i1=0;
  uint8_t i =0;
  float a;
  for (i=0;i<20;i++)
  {
    eeprom_read_block(&a,&schalt[i],sizeof(float));
    if (a != sch[i])
    {
      eeprom_write_block(&sch[i],&schalt[i],sizeof(float));

      //eeprom_write_word(&schalt[i], i1); 
    }
  }
} 

ausgang:
 void var_aus_eeprom () //Schaltwerte aus eeprom in RAM lesen - eimaliger Aufruf in main.c
{
  uint8_t i =0;
  float a;
  eeprom_read_block(&a,&schalt[19],sizeof(float));
  if (a == sch[19])
  {
    for (i=0;i<20;i++)
    {
      eeprom_read_block(&sch[i],&schalt[i],sizeof(float));
    }
  }
    uint8_t schaltautomatik = 0;

    sch[0] = rueckgabe("s00",index,sch[0]); // variablenübernahme von webseite (Schaltwerte)
    sch[1] = rueckgabe("s01",index,sch[1]);
    sch[2] = rueckgabe("s02",index,sch[2]);
    sch[3] = rueckgabe("s03",index,sch[3]);
    sch[4] = rueckgabe("s04",index,sch[4]);
    sch[5] = rueckgabe("s05",index,sch[5]);
    sch[6] = rueckgabe("s06",index,sch[6]);
    sch[7] = rueckgabe("s07",index,sch[7]);
    sch[8] = rueckgabe("s08",index,sch[8]);
    sch[9] = rueckgabe("s09",index,sch[9]);
    sch[10] = rueckgabe("s10",index,sch[10]);
    sch[11] = rueckgabe("s11",index,sch[11]);
    sch[12] = rueckgabe("s12",index,sch[12]);
    sch[13] = rueckgabe("s13",index,sch[13]);
    if(schaltwerte_geaendert == 1){var_in_eeprom();} // geänderte Variablen in eeprom schreiben (Schaltwerte)


wie gesagt eine ausgabe der werte sind vorhanden... sobald ich im 
formular senden drücke und er irgendwas im eeprom speichert funktioniert 
es noch kurz und nach ner zeit hängt es sich anscheinend auf ... ist 
evtl. eine schleife drin oder sowas ? weiß nicht mehr weiter

mfg Tony

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.