mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega48 Oscillator


Autor: Edward Cardew (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich wollte mal vom MCS51 Strucktur weg und habe ein paar atmega48
gekauft. Ich habe eine Schleife gemacht fuer PortD und mit internem
Oscillator laeuft er. Jetzt will ich das ganze mit 12MHz Xtal. Ich
denke fuses all aus, CKSEL=1111, SUT=10 und schon laeuft es aber NIX,
der Osci schwingt nicht an.

Ich programmiere mit GALEP4 ohne probleme.

Irgend was habe ich uebersehen aber was?

Excuse my miserable German,

Edward

Autor: Edward Cardew (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist schon gut,

Dummer Fehler, wenn mann neu anfaengt weiss mann nie was man macht, da
gibt es so viele neue Sachen die mann beachten muss. Es fehlt die
Routine.

(Loetfehler) !!!

Edward

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.