mikrocontroller.net

Forum: Compiler & IDEs WinAVT und AVR Studio + JTAG


Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verwende WinAVR und JTAGICE mit AVR Studio zum Debug.
Leider springt (aber nur teilwese) das AVR Studio an die falsche Stelle
bei einem Funktionsaufruf. Der Controller scheint aber die "richtigen"
Befehle auszuführen...
Weis hier einer Rat?
Ich verwende das dwarf-2 Format um die elf-Datei zu erzeugen

Autor: Werner B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stichwort: Optimierung

Der compiler optimiert warscheinlich einige teile so dass einiges
komplett verschwindet oder wegen laufzeitanalyse an eine andere stelle
verschoben worden ist. Das ist (leider) teil des software-lebens ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.