mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Timer / Output Compare Mode beim Atmge16


Autor: Christoph (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte mit dem 16bit-Timer des Atmega16 eine Zeitmessung
durchführen und dafür den Output-Compare-Mode nutzen.

Nachdem mein Code zu keinem Ergebnis führte (der nach einer Sekunde
erhoffte Interupt blieb aus) schaute ich mich hier um und stieß auf
Code von Peter Dannegger, der meinem aber weitestgehend glich. Aber
auch mit seinem Codebeispiel (das etwas adaptiert wurde (blinkende LED
als Ausgabe) und sich im Anhang befindet) läuft's nicht. Habe ich
etwas übersehen?

Gruß
Christoph

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.