mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MREAD auf sed1335


Autor: Igor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich versuche gerade den SED1335 von einem AVR (ATMEGA8515 16Mhz)
Mikrocontroller anzusteuern. Alles klappt prima, nur das Lesen (MREAD)
funktioniert nicht. Wenn ich den Befehl 0x43 an den SED1335 schicke
(A0=1, /RD=1, /WR=0), bekomme ich nach dem Lesen (A0=0, /RD=0, /WR=1)
auch 0x43 d.h. immer den letzen Datensatz aber eben nicht die Daten aus
dem Speicher (VRAM). Ich habe schon alles 10mal geprüft,  kann ich
jedoch keinen Fehler finden (weder technisch noch in Software).
Kann mir jemand vielleicht hier helfen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.