mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Watch Dog ausschalten


Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schaut mal bitte, ich hab mal mit dem Watch Dog im Simulator etwas
rumgespielt.
Ich schalte ihn ein, und wenn ich das Z Flag setze wieder aus. Aber
eigentlich sollte dies doch garnicht gehn, da ich das WDTOE vorm
ausschalten doch garnicht gesetzt habe?! Im Datenblatt wird dieses Bit
allerdings auch nicht gesetzt, jedenfalls nicht beim deaktivieren,
sondern beim aktivieren!? Hab ich da was falsch verstanden, oder
wiederspricht sich da etwas?


Danke für Eure Hilfe

    in  temp,wdtcr
    ori  temp,(1<<WDE)
    out   WDTCR,temp
main:
    wdr
    nop

    brne  main

    ldi  temp, (0<<WDE)
    out  WDTCR,temp

    rjmp  main

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.