mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Debugging


Autor: Izoard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich habe ein Problem beim Debuggen meines Programms:

Ich setze denn Pind auf $20, sobald ich jedoch einen step mache, löscht 
sich dieser automatisch! Weiss jemand, wieso das sein kann???

IZOARD

Autor: mikki merten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Setzt du diesen auch korrekt im I/O-Window ?

Autor: Izoard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ich setze ihn beim PIND 0x20!!!

Autor: René König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Äh, PIND ist doch eigentlich Read-Only. Du möchtest doch bestimmt in 
PORTD schreiben oder?

Autor: Izoard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich möchte das Programm simulieren und dann setze ich denn PIND!!!

Autor: Oliver Kullnick (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst Du mal ein Codefragment der Abfrage des Ports posten?

Gruß
Oliver

Autor: thkaiser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist Du Dir sicher, daß der DDRD für diesen Portpin "0" ist?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.