Forum: Mikrocontroller und Digitale Elektronik Bin ich ein Idiot? Probleme mit Interrupt Schaltung


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Rico S. (donricone)


Bewertung
-1 lesenswert
nicht lesenswert
Heey zusammen

Kleine Frage, irgendwie hänge ich ziemlich.

Habe mir gestern einen kleinen Laptimer (Stopuhr, mit Reedsensor statt 
Taster) gebastelt.

Funktioniert auch einwandfrei, aber jetzt kommts.

Habe die Schaltung bisher immer über Netzteil betrieben und heute 
erstmals mit Batterien über LM7805, da fiel mir auf, dass das Display 
bei jedem Impuls deutlich dunkler wird.

Der Reed sensor hängt am Interrupt 0,  Pin ist auf Eingang, High, und 
ist gegen GND geschalten. Das ergibt doch nen kurzen eig. nicht Zwecks 
Pullup oder etwa doch und ich bin ein Idiot?

Das ganze hängt an nem Mega8A

Danke schonmal

: Gesperrt durch User
von Marcus W. (marcusaw)


Bewertung
2 lesenswert
nicht lesenswert
Ja, du bist ein Idiot. Es fehlen Schaltplan, layout, Foto, Sourcecode, 
eigentlich alles. Dass das Display dunkler wird, kann etwa 300 Gründe 
haben - angefangen von zu niedriger Spannung bis hin zu zu hoher Last.

von Jürgen (Gast)


Bewertung
0 lesenswert
nicht lesenswert
>>Das ergibt doch nen kurzen eig. nicht Zwecks
Pullup oder etwa doch...


Ist das eine Frage, eine Antwort, oder fehlt in dem Satz was?

>>und ich bin ein Idiot?

Wie soll das hier jemand beurteilen ohne dich zu kennen?

JJ

von Rico S. (donricone)


Bewertung
0 lesenswert
nicht lesenswert
Jürgen schrieb:
>>>Das ergibt doch nen kurzen eig. nicht Zwecks
> Pullup oder etwa doch...
>
> Ist das eine Frage, eine Antwort, oder fehlt in dem Satz was?
>
>>>und ich bin ein Idiot?
>
> Wie soll das hier jemand beurteilen ohne dich zu kennen?
>
> JJ

Ich danke dir vielmals :)

Dann liegt das Problem wo anderst, vermutlich einfach an der Versorung, 
da der 7805 ja nen ziemlichen Drop hat/braucht!

: Bearbeitet durch User
von Rico S. (donricone)


Bewertung
0 lesenswert
nicht lesenswert
Problem gelöst vielen dank, bisschen mehr Saft und es passt wieder 
alles.

Dieser Beitrag ist gesperrt und kann nicht beantwortet werden.