mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Frage zum I2C-(TWI)-Interface vom ATmega88


Autor: Vikinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Im Datasheet vom ATmega88 (doc2545.revF S.212) steht das man für den
maximalen I2C-Takt von 400kHz mindestens 14,4MHz CPU-Takt braucht,
hab ich das richtig verstanden oder ist da irgentwo der Wurm drin.

Wie darf ich den Text hinter "Note:" verstehen?
Was kommen den für Fehler wenn TWBR kleiner als 10 ist?

Für den Slave-Mode reichen doch I2C-Clock * 16 als CPU-Takt, warum
reicht das für den Master-Mode nicht?

Grüße
Erik

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.