Forum: Mikrocontroller und Digitale Elektronik WT9501M03 MP3 Modul mit SD-Card


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Dirk H. (dirk09)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Gemeinde,

ich dachte mir zum Sonntag mal eine kleine Spielerei mit einem 
MP3-Soundmodul zu machen…
Mittlerweile wird der Spaß aber zum Frust, denn nix funktioniert.

Aber mal von vorn:
Von einiger Zeit habe ich das Soundmodul WT9501M03 mal gekauft und 
wollte es heute mal testen.
- Blick in Manual: Spannung +5V angelegt, grüne LED links oben leuchtet, 
freu

- 5 verschiedene SD-Karten unterschiedlicher Größe, auch HC 
herzugesucht, frisch mit FAT formatiert und kurze mp3-Files mit der 
Dateinennung 00001.mp3 usw. direkt ins Root-Dir. mittels separatem 
Cardreader drauf gemacht und ins Modul gesteckt.

- An die 6 Key-Eingänge je einen Taster gegen GND geschaltet, einen 
Mini-Lautsprecher angeschlossen und gelauscht……

- Auf keinen Tastendruck kam irgend eine Reaktion, bei keiner der 
Karten.

- Mist ! also die google-maschine angeschmissen und hier im Forum 
gesucht.
  sehr dürftig die Ausbeute.

- Ein youtube-Video gefunden : 
https://www.youtube.com/watch?v=UriYMzy4-1Y
Leider nicht in deutsch oder englisch. Aber der Clip verrät, dass an der 
Busy-Leitung eine kleine LED hängt, die leuchtet, wenn ein Titel gerade 
abgespielt wird.
Bei mir hat die LED nie geleuchtet.

- Also geh ich mal davon aus, dass das Modul die SD-Karte und/oder die 
mp3-File nicht erkennt.

- An Rx/Tx ein Terminal angeschlossen und versucht mit dem Modul zu 
sprechen:
auf Befehle wie 7E 02 A6 7E  „Play next file“ bekomme ich als Antwort 02 
A6 zurück.
Also genau der Befehl, den ich gesendet habe, nur ohne Start/Stop.
Das gleiche bei allen anderen ausprobierten Befehlen.

- Zeigt also erstmal, dass der Controller arbeitet, aber eben nix 
abspielt.

Frage nun an Euch, die Ihr ja schon so einigen Module und Bausätze habt 
untersucht und auf die Beine geholfen: Hat wer sich auch schon mal mit 
diesem Modul beschäftig, mit welchem Ergebnis.
Hat jemand Tipps und Anhaltspunkte zum Suchen?

Freu mich auf Eure Antworten und wünsche einen schönen Sonntag!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.