mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik reset wenn am isp??


Autor: Jonas Diemer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich benutze zum programmieren nen selbergebastelten ISP dongle für den 
parport (nach dem schaltplan von lancos.com, der aber weitgehend 
identisch mit dem hier verlinkten ist).

wenn ich nun ein programm schreibe, das ne led am port b umschaltet, so 
wird bei jedem ANSCHALTEN der led ein RESET aus geführt.

die passiert aber nur, wenn der isp angeschlossen ist.

woran kann das liegen? bricht vcc irgendwo ein?

vor allem: wie kann ich das beheben?

Autor: Jonas Diemer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HI!

habs repariert: hab zwischen reset und gnd statt des 47pF kondensators 
einen mit 100nF genommen. geht nun wunderbar.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.