mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LM75 routine


Autor: mrpink (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spiele mich schon seit einiger Zeit mit dem LM75 IIC Temp sensor.

Irgendwie komm ich aber leider nicht ganz zurecht.

Der Temperaturwert liegt in einem Register
0x00 Temperature (Read only) (Power-up default)

1. Start condiditon
2. Adresse mit attribut read übermitteln (0b10010000)

und jetzt komm ich nicht mehr ganz klar - im datenblatt steht
folgendes:

When SLA+R have been transmitted and an acknowledgement bit has been
received,
TWINT is set again and a number of status codes in TWSR are possible.
Received data can be read from
the TWDR Register when the TWINT Flag is set high by hardware.

Welche flags muss ich nach dem übermitteln der adresse setzten damit
ich dem ding sage das er auf daten warten soll?

bitte um hilfe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.