mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Davicom DM9000 Verbindung mit Switch ADM6996i


Autor: Andraes154655 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich brauche nen Tipp warum die Verbindung zwichen den beiden Chips
nicht Funzt? Der Switch Funzt; der Davicom Funzt auch wenn er direkt mit
dem Netzwerk angeschlossen ist. nur wenn er via Switch mit dem Netzwerk
laufen soll gehts nicht. Ich dachte in meinem jugendlichem Leichtsinn
ich kann die Verbindung direkt ausführen nur mit Kondensatoren
gekoppelt aber dem ist wohl nicht so. wenn ich statt der Kondensatoren
auf RJ45 Buchsen raus... über Kabel und wieder über RJ 45 rein zum
Switch gehe läufts.
Brauch ich etwa unbedingt nen Übertrager zwischen Switch und DAVICOM
??????

Wer hat nen Tipp für mich.
Schaltung ist im Anhang.
Gruss Andreas

Autor: Andraes154655 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergass das ganze läuft bei mir an einem ARM STR710 und GNU-C von
http://www.st-angliamicro.com/software.asp

Autor: Andraes154655 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke

Autor: Sven Bohner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Layer2- oder Layer3-switch???

hast du ARP, ICMP... ...und die routing-protokolle soweit
implementiert??? (evtl dhcp?)

Autor: Andraes154655 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Switch braucht keine Software der machs soweit alleine
es funktioniert ja aber eben nur wenn ich den Switch via RJ45 buchsen
mit dem DAVICOM verbinde statt wie im schaltplan dargestellt mit
10 nF Kondensatoren.
DAVICOM und SWITCH sitzen auf einer Platine und sollen direkt
kommunizieren mit einfacher beschaltung.
Das ganze ist ein Hardwareproblem!!

Warum macht der Davicom nicht direkt und auf kürzester Verbindung mit
dem ADM6996 (6fach Switch jedoch nur 3 benutzt).

Zur Software PING mit DM9000 läuft schon.

Autor: Jörn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Andreas,

ich kann dir direkt nicht helfen, würde dir aber empfehlen dich mal mit
Davicom in Verbindung zu setzen. Die können dir vielleicht helfen.

Kannst du deine Initialisierung des DM9000s mal posten. Ich bringe den
Chip nicht dazu mit mir zu reden.

Gruß Jörn

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.