mikrocontroller.net

Forum: Compiler & IDEs wenn ich den "wert" erhöhe, kommt immer die zahl von atoi


Autor: neuer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo, wenn ich mit atoi den wert einlese und ihn noch um 2 erhöhe z.b.
,wird immer nur der wert ausgegeben ohne die adition.


neuer

uint16_t wert;
  char buffer[7];

  sei();
  usart_init( (READ + WRITE) , READ);
  lcd_init(LCD_DISP_ON);
  lcd_clrscr();

   while(1)
  {
        wert=atoi(satz_ausgabe);
    wert=wert+2;
    itoa( wert , buffer, 10);
    lcd_clrscr();
    lcd_puts(satz_ausgabe);
    delay_ms(100);
  }

Autor: neuer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat sich erledigt.......

neuer

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.