Forum: Mikrocontroller und Digitale Elektronik Flashen ATmega16


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Messfux (Gast)


Lesenswert?

Mittels Ponyprog will ich einen Atmega16 flashen, aber der µController 
wird nicht erkannt.

ISP Programmer (Eigenbau) funktioniert hervorragend mit AT90S4433 &2312. 
Die Platine für den ATmega ist Eigenbau.

Habe ich das richtig verstanden:

Der Mikrocontroller ist ab Werk auf internen Oszillator eingestellt, ein 
externer Quarz ist also nicht nötig, die Frequenz stelle ich auf 1 MHZ 
in der zu flashenden Software.
An den Reset-PIN habe ich einen 150 kOhm-Widerstand auf 5V, sowie einen 
100nF-Kondensator auf GND gelegt. Stromversorgung mit 100nF zwischen + 
und GND.
Weitere Beschaltung ist nicht notwendig.

Kann mir jemand weiterhelfen?

Gruß Messfux

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.