mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Nodemcu V2 kommunikations Probleme UART


Autor: Jens D. (jens) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein Problem mit der Kommunikation zum Modul.
Wenn ich die LUA Befehle einzeln an das Modul schicke werden diese 
korrekt ausgeführt.
Wenn ich jedoch ein Script über ESPlorer an das Modul sende (entweder 
zum speichern oder direkt zum ausführen) scheint das Modul die Daten 
nicht korrekt zu empfangen.
Es ist auch egal, welche Geschwindigkeit ich einstelle immer das 
gleiche.

Jens

Autor: Peter II (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eventuell muss man ja nach jeden Befehl die Bestätigung abwarten.

Autor: Timmo H. (masterfx)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die Probleme hatte ich auch.
Entferne den Haken bei "Dumb Mode", dann sollte es klappen

: Bearbeitet durch User
Autor: Jens D. (jens) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

super danke das funktioniert.
Komisch ist nur, dass es vorher geklappt hatte. Keine Ahnung warum.

Jens

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.