mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISD1700 mit SPI REC funktioniert nicht


Autor: Duri Brander (dubrain)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liebe Mikrocontroller User

Ich möchte mit einen ATmega644P einen Soundchip ISD17240 über SPI 
ansteuern.
Kommunikation klappt soweit aber ich kann über AnaIn nicht aufzeichen.

Chip im SPI mode:
D6/FT ein/aus = ok
PLAY befehl =ok
STOP = ok
RESET = ok

REC will einfach nicht :-(

Codeschnipsel:

WriteAPC2(0b00010000, 0b00000100);
 Record();        // 0x41
  _delay_ms(5000);
 Stop();    // 0x02

Gemäss APC2 müsste FT während der Aufnahme aus sein. Ist sie aber nicht. 
Und aufnehmen tut der Chip auch nicht.

Ich bin über jeden Tip froh den ihr für mich habt.

Gruss Duri

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.