mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik TWI / I2C verzögerter Restart des Busses


Autor: Borsty Bürste (Firma: www.waechter-bernhard.de) (mantabernd)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

mir ist grad aufgefallen dass ich scheinbar einen Bug im I2C Protokoll 
habe.
Wie auf dem Screen zu sehen wird der Restart des Busses ziemlich 
hinausgezögert.

Es funktioniert zwar, kommt mir aber komisch vor.

Was meint ihr dazu?

Gruß Bernhard

Autor: Joe F. (easylife)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht so aus wenn der Slave für die Verarbeitung des 2. Bytes einfach 
etwas Zeit benötigt, und das ACK standardgemäss per clock stretching 
hinauszögert. Alles OK also.

: Bearbeitet durch User

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.