mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit M16C -> delay implementation


Autor: Peter Dobromyslov (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich versuche gerade ein delay funktion auf Basic von Timer B1 zu
implementieren. Das funktioniert wunderbar nur mit debugger, aber
sobald ich das flashe, hängt das board während TimeoutFlag Abfrage.  Es
sieht so aus, ob Timer so stark prozessor belastet, dass es keine
Resources mehr frei gibt.

Woran kann das noch liegen? Was ist der Unterschied zwieschen debug und
flash Version? zur Info: für Debuggen benutze ich E8.

Code -> sehe Anhang.

Autor: peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schon gelöst!!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.