mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Übertragungsfehler immer bei 15%???


Autor: Lothar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe hier ein Problem mit PonyProg:
Beim Übertragen meiner Programme auf den AVR bleibt der Fortschritts
anzeiger bei 15% stehen, dann dauerts ein bisschen, und schlussendlich
meldet Ponyprog, dass es einen Fehler gab.

Ich verwende einen selber gelöteten ISP Adapter (Parallelport).
Das komische ist, dass das ganze mit sehr kleinen Programmen kein
Problem ist. Nur wenn sie größer werden (AVR-Studio sagt, dass bei dem
es nicht klappt belege 35% der Chip-Kapazität) wird es schwierig.
Biseher hat das zwar immer noch nach einigen dutzend Versuchen doch
geklappt, aber jetzt komischerweise garnicht mehr (wie gesagt, mit
kleinen Programmen geht's nach wie vor).

Hat jemand eine Idee, was ich da tun könnte? Das Kabel des ISP ist
übrigens nicht besonders lang (knappe 30cm)...

Danke!!!
:-)

Autor: Daniel R. (daniel_r)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist das falsche Unterforum...Du hättest unter "µC & Elektronik"
posten sollen...aber seinen wir mal nicht so...
Du könntest versuchen, den SPI Clock bei der Übertragung zu reduzieren.
Ich kenne Pony-Prog leider nicht, aber das geht bestimmt...
Desweiteren könntest Du versuchen mal nen Chip-Erase zu machen, sodass
der AVR leer ist. Bei mir half das bei solchen Fällen schon.


Gruß

Daniel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.