mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Soundausgabe funktioniert nicht!!!


Autor: Ludwig Wagner (lordludwig)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

im Anhang erstmal meine schaltung, mein Assembler programm und 2
sounddateien wie es sich anhören sollte und es sich anhört.

Also, ich habe das ganze wie im Schaltplan zu sehen zusammengebaut und
bekomme beim anschalten - auch schon vor dem Programmieren - diesen
komischen piepton mit kleinen knacksern zwischendrinn. Ich denke da
schwingt irgendwas aber wo schwingt was???

In der routine sollte mit einer frequenz von 8khz immer ein byte der
WAVE datei ohne header (8khz, mono, 8 bit) unten ausgegeben werden.
Aber auch das funktioniert anscheinend nicht, da es einfach
weiterpfeift wenn ich den uC programmiert habe.

funktioniert vieleicht das I²S protokoll anders oder ist gar meine
schaltung falsch???

was mir aufgefallen ist das der TDA1543 auch ohne ausgabe leicht warm
wird ist das vlt. die quelle für die schwingungen???

Ich danke für jede antwort und alle bemühungen!!!

Autor: Ludwig Wagner (lordludwig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
stellen wir die frage mal ganz einfach: woran kann es liegen das ein wie
im schaltplan beschalteter TDA1543 so pfeift???

Autor: Ludwig Wagner (lordludwig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK liegt 100% am TDA1543, ohne uC pfeift es auch und ohne TDA1543
nicht!!!

also was ist an meiner beschaltung des TDA1543 falsch?

Autor: Ludwig Wagner (lordludwig)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
vlt. bringts ja was im anhang die wellenform ziemlich genau 4kHz

Autor: Michael Frangenberg (startrekmichi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja ja, die lieben Datenblätter...
- Pfeifen durch Einsetzen des Rbias behoben.

Autor: Ludwig Wagner (lordludwig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da stand aber "optional"

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.